mokacoding

unit and acceptance testing, automation, productivity

How to update all plug-ins for the latest version of Xcode and Xcode-beta

Today I installed the latest beta version of Xcode, Xcode 7.3 beta 4. As usual none of my plug-ins worked, which makes me really unproductive.

So I went back to this post in which I showed how to update a plug-in to be compatible to the latest version of Xcode. I made an handy script out of it that will update all plug-ins to be compatible with the version of Xcode and Xcode-beta installed on your machine.

Here it is in gist form, so that this post will always show an up to date version.

I hope you found it useful. If you need any help let me know by getting in touch on Twitter @mokagio, or leaving a comment below.

Leave the codebase better than you found it.

Vote on Hacker News